FreshBooks - Component not working

Incident Report for FreshBooks

Resolved

We have resolved the issue impacting FreshBooks. Thank you for your patience while we worked to fix the issue. Check back here for any further updates.
Posted Sep 23, 2022 - 09:00 EDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Sep 22, 2022 - 06:18 EDT

Identified

The issue has been identified and a fix is being implemented.
Posted Sep 22, 2022 - 06:05 EDT

Investigating

There’s currently an issue with creating new Invoices, Estimates, and Proposals on FreshBooks. We’ve identified the problem and are working to fix it, however you may be unable to use Invoices, Estimates, and Proposals at this time.
Please check back for further updates.
Posted Sep 22, 2022 - 05:45 EDT
This incident affected: FreshBooks.