Degraded Performance in New and Classic FreshBooks
Incident Report for FreshBooks
Resolved
FreshBooks availability has been restored, New and Classic FreshBooks are now fully operational. We apologize for any inconveniences this may have caused.
Posted 14 days ago. Jul 02, 2019 - 12:27 EDT
Monitoring
A fix has been implemented for the reported downtime and we're monitoring the results.
Posted 14 days ago. Jul 02, 2019 - 12:20 EDT
Update
We are continuing to investigate this issue.
Posted 14 days ago. Jul 02, 2019 - 11:42 EDT
Update
Currently we are experiencing some degraded performance in FreshBooks. We apologize for the inconvenience and are investigating the cause. Please check back for updates
Posted 14 days ago. Jul 02, 2019 - 11:41 EDT
Investigating
Currently we are experiencing some technical issues. We apologize for the inconvenience and are investigating the cause. Please check back for updates.
Posted 14 days ago. Jul 02, 2019 - 11:32 EDT
This incident affected: FreshBooks and FreshBooks Classic.