FreshBooks - Email Delivery
Incident Report for FreshBooks
Resolved
We have resolved the issue impacting email delivery. Thank you for your patience while we worked to fix the issue.
Posted Jun 08, 2021 - 16:56 EDT
Monitoring
We have fixed the issue impacting email delivery and will continue monitoring our fix to ensure there are no further issues. Feel free to check back here for any further updates.
Posted Jun 08, 2021 - 15:21 EDT
Identified
There’s currently an issue with email delivery on FreshBooks. We’ve identified that emails are not being delivered to their intended recipients and we're working diligently to resolve this issue. Please check back for further updates.
Posted Jun 08, 2021 - 13:44 EDT
This incident affected: FreshBooks and FreshBooks Classic.