Degraded Performance in New and Classic FreshBooks
Incident Report for FreshBooks
Resolved
This incident has now been resolved.
Apologies for any inconvenience caused.
Posted 28 days ago. Nov 19, 2018 - 17:17 EST
Update
We are continuing to investigate this issue.
Posted 28 days ago. Nov 19, 2018 - 16:59 EST
Investigating
FreshBooks is currently experiencing intermittent availability issues. We are working on a fix and will update here once all is resolved. Thank you for your patience.
Posted 28 days ago. Nov 19, 2018 - 16:57 EST
This incident affected: FreshBooks, FreshBooks Classic, Automatic Expense Import, and FreshBooks Payments.