FreshBooks - Component not working

Incident Report for FreshBooks

Resolved

We have resolved the issue impacting FreshBooks. Thank you for your patience while we worked to fix the issue. Check back here for any further updates.
Posted Aug 31, 2022 - 09:42 EDT

Monitoring

We have fixed the issue impacting FreshBooks, and will continue to monitor it to ensure there’s no further downtime. Feel free to check back here for any further updates.
Posted Aug 30, 2022 - 17:59 EDT

Investigating

There’s currently an issue with accessing or updating your FreshBooks subscription plan. We’ve identified the problem and are working to fix it, however you may be unable to access that area at this time. Please check back for further updates.
Posted Aug 30, 2022 - 16:17 EDT
This incident affected: FreshBooks.