New FreshBooks Unavailable for Safari Version 10.1 Users
Incident Report for FreshBooks
Resolved
This incident has been resolved.
Posted over 1 year ago. Mar 29, 2017 - 10:41 EDT
Identified
Thank you for your patience while we work on a resolution.
Posted over 1 year ago. Mar 29, 2017 - 09:55 EDT
Update
While the current issue with Safari version 10.1 is being worked on, please consider using the Chrome browser until this is resolved. Our sincere apologies for any inconvenience.
Posted over 1 year ago. Mar 28, 2017 - 15:58 EDT
Investigating
We are currently investigating this issue.
Posted over 1 year ago. Mar 28, 2017 - 14:23 EDT
Identified
The issue has been identified and a fix is being implemented.
Posted over 1 year ago. Mar 28, 2017 - 14:10 EDT
Investigating
New FreshBooks is currently unavailable for customers using the newest version of Safari version 10.1. Firefox and Chrome are currently unaffected. Technicians are working hard to restore service as soon as possible.
Posted over 1 year ago. Mar 28, 2017 - 14:08 EDT