Phone System Issue
Incident Report for FreshBooks
Resolved
The issue we were experiencing with our Phone System not being able to connect calls has now been resolved. Thank you for your patience.
Posted Nov 17, 2021 - 09:00 EST
Identified
We have identified the cause of issue affecting our phone system. Our phone lines are open but Canadian callers may experience issues connecting due to an ongoing investigation with a third-party vendor (status.twilio.com). If you are having trouble connecting, visit support.freshbooks.com or email support@freshbooks.com. Thanks for your patience.
Posted Nov 15, 2021 - 16:51 EST
Investigating
We have reverted back to investigating the issue with our phone system's inability to connect calls. Callers will receive a message referring them to email support and our FAQ pages. We will update once we have more info. Please visit support.freshbooks.com for FAQs or send an email to support@freshbooks.com for help. We appreciate your patience while we sort this out.
Posted Nov 15, 2021 - 15:52 EST
Monitoring
We have implemented a fix for the issue affecting our phone system's inability to connect calls. Calls are currently connecting successfully and we are monitoring the fix. We will post another update once we're confident that the issue is fully resolved. Please note that you can also visit support.freshbooks.com or email support@freshbooks.com for assistance.
Posted Nov 15, 2021 - 14:08 EST
Investigating
We are currently investigating an issue with our phone system not being able to connect calls. We will update as we find out more. Please visit support.freshbooks.com for FAQ's and help or send us an email to support@freshbooks.com. Thank you.
Posted Nov 15, 2021 - 12:34 EST