Access issues
Incident Report for FreshBooks
Resolved
We have resolved the issue impacting FreshBooks. Thank you for your patience while we worked to fix the issue. Check back here for any further updates.
Posted Dec 02, 2021 - 10:14 EST
Monitoring
We have fixed the issue impacting FreshBooks, and will continue to monitor it to ensure there’s no further downtime. We thank you and appreciate your patience while we worked to fix this issue.
Posted Dec 01, 2021 - 16:24 EST
Update
Our New FreshBooks and Classic FreshBooks platforms are available for use again. We are continuing to investigate and monitoring performance at this time. Further updates will be provided as soon as they are available. Again, we thank you and appreciate your continued patience.
Posted Dec 01, 2021 - 14:22 EST
Update
We are continuing to investigate this issue.
Posted Dec 01, 2021 - 13:57 EST
Update
Our New FreshBooks and Classic FreshBooks platforms are currently unavailable. We continue to work towards remediation at this time and updates will be provided as soon as they are available. We thank you for your patience.
Posted Dec 01, 2021 - 13:42 EST
Update
We are continuing to investigate reports of latency in our New FreshBooks and Classic FreshBooks platforms. While our investigation continues, remediation efforts are currently being explored. PDF downloads have been disabled while we research our opportunities to resolve this issue globally.
Posted Dec 01, 2021 - 12:53 EST
Update
We are continuing to investigate this issue.
Posted Dec 01, 2021 - 12:15 EST
Investigating
We are currently investigating an access issue affecting the FreshBooks platform. Users may be have trouble logging in, loading various pages and/or downloading PDFs. We will post another update shortly. Please subscribe to our status page to receive email updates as we progress. Thank you for your patience.
Posted Dec 01, 2021 - 12:00 EST
This incident affected: FreshBooks, FreshBooks Classic, Android App, and iOS App.