Degraded Performance in new and Classic FreshBooks
Incident Report for FreshBooks
Resolved
The issue is now resolved, new and Classic FreshBooks is now fully operational.
Posted over 1 year ago. Jul 24, 2017 - 13:55 EDT
Monitoring
We identified the issue and we are working on resolving the slowness in new and Classic FreshBooks.
Posted over 1 year ago. Jul 24, 2017 - 13:37 EDT
Investigating
We are experiencing degraded performance in new and Classic FreshBooks which are operations team is investigating
Posted over 1 year ago. Jul 24, 2017 - 12:09 EDT