FreshBooks Payments may be unavailable.
Incident Report for FreshBooks
Resolved
This incident has been resolved.
Posted Apr 04, 2020 - 00:13 EDT
Monitoring
A fix has been deployed. We will continue to monitor FreshBooks Payments to ensure systems are operating correctly.
Posted Apr 04, 2020 - 00:03 EDT
Identified
We have identified the issue and teams are evaluating remediation options.
Posted Apr 03, 2020 - 23:26 EDT
Investigating
We are currently investigating an issue with FreshBooks Payments. This may affect access to payment options and some invoice may be unable to use FreshBooks Payments.
Posted Apr 03, 2020 - 23:19 EDT
This incident affected: FreshBooks Payments.