FreshBooks - Issue with Invoices & Recurring Templates
Incident Report for FreshBooks
Resolved
We have resolved the issue impacting FreshBooks. Thank you for your patience while we worked to fix the issue. Check back here for any further updates.
Posted Apr 20, 2022 - 14:23 EDT
Update
We are continuing to investigate this issue.
Posted Apr 20, 2022 - 11:36 EDT
Investigating
There’s currently an intermittent issue which is causing degraded performance with invoices & Recurring Templates. We are investigating the issue & will keep you updated as we work towards resolving this issue.
Posted Apr 20, 2022 - 11:30 EDT
This incident affected: FreshBooks.