FreshBooks - Email Delivery Delay
Incident Report for FreshBooks
Resolved
We have resolved the issue impacting Email Delivery in FreshBooks. Thank you for your patience while we worked to fix the issue. Check back here for any further updates.
Posted Mar 09, 2021 - 14:45 EST
Monitoring
We have implemented some resolutions to the issue impacting Email Delivery and we're noticing improvements in delivery times. However, we are still experiencing delays and we will continue to monitor the situation until it is full resolved. Feel free to check back here for any further updates.
Posted Mar 09, 2021 - 12:49 EST
Investigating
There’s currently an issue concerning delays in Email Delivery on FreshBooks. We’ve identified the problem and are working to fix it, however emails of invoices, estimates, reports, notifications and reminders will have a longer than normal delivery time. Please check back for further updates.
Posted Mar 09, 2021 - 11:06 EST
This incident affected: FreshBooks and FreshBooks Classic.