FreshBooks - Access Issues

Incident Report for FreshBooks

Resolved

This incident has been resolved.
Posted Oct 20, 2025 - 14:58 EDT

Identified

We’re currently experiencing an issue which may prevent users from accessing FreshBooks. As a result, you may experience problems with recieving 2FA emails while we work to fix the problem. We will post another update as soon as we have more information.
Posted Oct 20, 2025 - 13:53 EDT
This incident affected: FreshBooks.