FreshBooks & FreshBooks Classic
Incident Report for FreshBooks
Resolved
We have resolved the issue impacting FreshBooks and FreshBooks Classic. Thank you for your patience while we worked to fix the issue. Check back here for any further updates.
Posted Apr 20, 2020 - 12:18 EDT
Monitoring
We will continue to monitor our systems over the evening to ensure there’s no further interruption to service. If there are additional updates we will post them here.
Posted Apr 16, 2020 - 16:15 EDT
Update
Webapp Functionality of FreshBooks & FreshBooks Classic have now been restored but you may notice intermittent delays with webhooks as we continue to monitor and fix the underlying issue. We will post additional updates as soon as we have them.
Posted Apr 16, 2020 - 13:43 EDT
Investigating
FreshBooks and FreshBooks Classic is currently having intermittent issues impacting login and causing partial outages and issues with functionality, our team is working hard to get it back up and running. We will post updates as soon as we have them.
Posted Apr 16, 2020 - 11:51 EDT
Monitoring
We have fixed the issue impacting FreshBooks and FreshBooks Classic, and will continue to monitor it to ensure there’s no further downtime. Feel free to check back here for any further updates.
Posted Apr 16, 2020 - 11:31 EDT
Investigating
FreshBooks & FreshBooks Classic are both currently down, and our team is working hard to get it back up and running. We will post updates as soon as we have them.
Posted Apr 16, 2020 - 11:18 EDT
This incident affected: FreshBooks and FreshBooks Classic.