FreshBooks - FreshBot not working

Incident Report for FreshBooks

Resolved

This incident has been resolved.
Posted Oct 24, 2025 - 11:13 EDT

Identified

There’s currently an issue with our support chat tool on FreshBooks. We've confirmed the issue is on our vendor's side and while we wait for updates, customers will be unable to use our chat tool to contact us. Instead, please reach out to support@freshbooks.com or 1-866-303-6061.
Posted Oct 24, 2025 - 10:49 EDT
This incident affected: FreshBooks.