FreshBooks - Intermittent Delays
Incident Report for FreshBooks
Resolved
We have resolved the issue that was causing intermittent slowness on FreshBooks. Thank you for your patience while we worked to fix the issue. Check back here for any further updates.
Posted Sep 16, 2021 - 15:18 EDT
Monitoring
We have fixed the issue that was causing intermittent slowness on FreshBooks and will continue to monitor it to ensure there are no further issues. Feel free to check back here for any further updates.
Posted Sep 15, 2021 - 16:10 EDT
Investigating
We’re currently investigating reports of an issue with intermittent slowness on FreshBooks. We will post updates as soon as we have them.
Posted Sep 15, 2021 - 14:55 EDT
This incident affected: FreshBooks.