FreshBooks - Investigating Issue with Email Delivery
Incident Report for FreshBooks
Resolved
We have resolved the issue impacting mail delivery in FreshBooks. Thank you for your patience while we worked to resolve the issue. Check back here for any further updates.
Posted Jun 17, 2022 - 16:11 EDT
Identified
We have identified the issue impacting email delivery, and remediation is underway. We will post an update as soon as the issue is resolved.
Posted Jun 15, 2022 - 10:08 EDT
Investigating
We’re currently investigating reports of an issue with email delivery in FreshBooks. Customers may find that there is a delay in emails being delivered. We will post updates as soon as we have them.
Posted Jun 13, 2022 - 14:11 EDT
This incident affected: FreshBooks.