FreshBooks - Shopify and Squarespace integrations disabled
Incident Report for FreshBooks
Resolved
This incident has been resolved.
Posted May 21, 2020 - 15:09 EDT
Investigating
We have temporarily disabled our Shopify and Squarespace integrations. We will post an update once the integrations have been re-enabled.
Posted May 08, 2020 - 12:16 EDT
This incident affected: FreshBooks and FreshBooks Classic.