Degraded Performance Processing Online Payments
Incident Report for FreshBooks
Resolved
The issue is now resolved and all components of FreshBooks are operational.
Posted 9 months ago. Jan 05, 2018 - 12:18 EST
Monitoring
We have identified a DNS issue which we are monitoring and are waiting for the TTL to expire which will resolve the issue.
Posted 9 months ago. Jan 05, 2018 - 11:46 EST
Identified
We have identified the cause of the issue and are working to resolve it.
Posted 9 months ago. Jan 05, 2018 - 11:20 EST
Investigating
We are currently experiencing an issue with degraded performance processing online payments on FreshBooks Invoices. We are investigating the issue and will update https://status.freshbooks.com once the issue is resolved.
Posted 9 months ago. Jan 05, 2018 - 11:04 EST