FreshBooks - Can't Unsubscribe From Marketing Emails
Incident Report for FreshBooks
Resolved
We have resolved the issue impacting FreshBooks. Thank you for your patience while we worked to fix the issue. Check back here for any further updates.
Posted Sep 26, 2022 - 13:03 EDT
Investigating
There’s currently an issue preventing customers from being able to unsubscribe from FreshBooks marketing emails at this time. We are working to resolve this issue so you can successfully unsubscribe from our marketing emails. Please check back for further updates.
Posted Sep 26, 2022 - 12:40 EDT
This incident affected: FreshBooks.