FreshBooks - Degraded Performance with Client Search
Incident Report for FreshBooks
Resolved
We have resolved the issue impacting FreshBooks. Thank you for your patience while we worked to fix the issue. Check back here for any further updates.
Posted Jul 14, 2022 - 13:29 EDT
Identified
The issue has been identified and a fix is being implemented.
Posted Jul 14, 2022 - 11:49 EDT
Investigating
There’s currently an issue causing degraded performance with Client Search on FreshBooks. We’ve identified the problem and are working to fix it. Please check back for further updates.
Posted Jul 14, 2022 - 11:44 EDT
This incident affected: FreshBooks.