New Account Subscription Issues
Incident Report for FreshBooks
Resolved
This incident has been resolved.
Posted about 2 months ago. Feb 21, 2019 - 16:43 EST
Monitoring
New account subscriptions are working normally again. We are now monitoring the recent fix.
Posted 2 months ago. Feb 20, 2019 - 18:18 EST
Investigating
FreshBooks is currently experiencing technical difficulties with newly created FreshBooks accounts. Our developers are currently investigating the issue. We apologize for any trouble you may be experiencing with your new FreshBooks account.
Posted 2 months ago. Feb 20, 2019 - 16:23 EST
This incident affected: FreshBooks and FreshBooks Classic.