FreshBooks - Down
Incident Report for FreshBooks
Resolved
The issue impacting FreshBooks downtime has been resolved. Thank you for your patience.
Posted Nov 16, 2021 - 14:04 EST
Monitoring
The issue that has caused the downtime we were experiencing is beginning to resolve and FreshBooks accounts are now accessible. We will continue to monitor the situation. Feel free to check back here for any further updates.
Posted Nov 16, 2021 - 13:18 EST
Investigating
FreshBooks is currently down and our team is working hard to get it back up and running. We will post updates as soon as we have them.
Posted Nov 16, 2021 - 13:02 EST
This incident affected: FreshBooks and FreshBooks Classic.