FreshBooks - Component not working
Incident Report for FreshBooks
Resolved
This incident has been resolved. Thank you for your patience while we worked to fix the issue.
Posted Sep 20, 2023 - 17:01 EDT
Monitoring
We have fixed the issue impacting the Account Billing Component of FreshBooks and will continue to monitor it to ensure there’s no further downtime. Feel free to check back here for any further updates.
Posted Sep 20, 2023 - 16:53 EDT
Investigating
There’s currently an issue with the Account Billing Component of FreshBooks. We’ve identified the problem and are working to fix it, however, FreshBooks Account Creation, as well as any Account Upgrades/Downgrades/Cancellations, are unavailable at this time.
Please check back for further updates.
Posted Sep 20, 2023 - 15:52 EDT
This incident affected: FreshBooks.