FreshBooks is currently unavailable to some users
Incident Report for FreshBooks
Resolved
Our upstream providers have fixed the problem causing access issues in FreshBooks. FreshBooks is now fully available.
Posted about 1 month ago. Jun 02, 2019 - 20:13 EDT
Update
FreshBooks continues to be in maintenance mode as we wait for resolution from our upstream providers.
Posted about 1 month ago. Jun 02, 2019 - 18:55 EDT
Update
FreshBooks continues to be in maintenance mode as we wait for resolution from our upstream providers.
Posted about 1 month ago. Jun 02, 2019 - 17:48 EDT
Update
FreshBooks is being taken down for planned maintenance. We will post an update when FreshBooks access has been restored.
Posted about 1 month ago. Jun 02, 2019 - 16:47 EDT
Monitoring
FreshBooks continues to monitor a larger internet related outage which is causing our services to be unavailable to a majority of users.
Posted about 1 month ago. Jun 02, 2019 - 16:39 EDT
Update
Some users are currently experiencing issues logging into FreshBooks. We are working to restore access for all users.
Posted about 1 month ago. Jun 02, 2019 - 15:49 EDT
Investigating
We are currently investigating this issue.
Posted about 1 month ago. Jun 02, 2019 - 15:43 EDT
This incident affected: FreshBooks and FreshBooks Classic.