New FreshBooks Access
Incident Report for FreshBooks
Resolved
FreshBooks availability has been restored. We apologize for any inconvenience this may have caused.
Posted about 1 month ago. Mar 13, 2019 - 15:03 EDT
Update
We are continuing to Investigate the Issue.
Posted about 1 month ago. Mar 13, 2019 - 14:49 EDT
Investigating
Currently we are experiencing some degraded performance in New FreshBooks. We apologize for the inconvenience and are investigating the cause. Please check back for updates
Posted about 1 month ago. Mar 13, 2019 - 14:46 EDT
This incident affected: FreshBooks.