FreshBooks loading slowly
Incident Report for FreshBooks
Resolved
The performance problems we encountered earlier today have been resolved.
Posted almost 2 years ago. Feb 09, 2017 - 15:02 EST
Monitoring
FreshBooks Classic and New FreshBooks response times have returned to normal, and we're monitoring the situation.
Posted almost 2 years ago. Feb 09, 2017 - 14:59 EST
Identified
We're aware of an issue causing FreshBooks Classic and New FreshBooks to load slowly and are rolling out a solution.
Posted almost 2 years ago. Feb 09, 2017 - 14:50 EST