FreshBooks Classic upgrades unavailable
Incident Report for FreshBooks
Resolved
The FreshBooks Classic Upgrade page is now available for all accounts. We sincerely apologize for any inconvenience caused!
Posted over 1 year ago. Jun 21, 2017 - 17:17 EDT
Update
The FreshBooks Classic Upgrade page is now available for the majority of accounts. We are continuing to move forward with a solution to ensure all accounts can access the Upgrade page. The rest of the FreshBooks Classic App continues to perform normally.
Posted over 1 year ago. Jun 21, 2017 - 16:05 EDT
Update
We are continuing to work on resolving the issue. As before, the FreshBooks Classic Upgrade page remains unavailable, while the rest of the app continues to perform normally. Stay tuned for further updates, we apologize for the inconvenience.
Posted over 1 year ago. Jun 21, 2017 - 14:52 EDT
Update
We are implementing the resolution for the issue and will continue to monitor. The FreshBooks Classic Upgrade page remains unavailable for the time being, the rest of the app is performing normally.
Posted over 1 year ago. Jun 21, 2017 - 13:29 EDT
Identified
We have identified the root cause of the issue and are working on a resolution. The FreshBooks Classic Upgrade page remains unavailable, the rest of the app is performing normally. We sincerely apologize for the inconvenience.
Posted over 1 year ago. Jun 21, 2017 - 12:31 EDT
Investigating
We are aware of an issue affecting the availability of the Billing and Upgrade pages in Classic FreshBooks. We are currently investigating the issue. The rest of the FreshBooks Classic app is performing normally.
Posted over 1 year ago. Jun 21, 2017 - 11:29 EDT