Payment gateway issues - Stripe
Incident Report for FreshBooks
Resolved
This incident has been resolved.
Posted Dec 14, 2022 - 14:49 EST
Monitoring
We have resolved the issue with Stripe. All functionality is back to normal and affected transactions have been updated with the correct status.
Posted Nov 28, 2022 - 12:04 EST
Investigating
FreshBooks is currently unable to process failed transactions through Stripe. Some users may find that information about failed direct debit payments is not appearing in their FreshBooks account. The team is aware of the problem and is working to resolve it. We will post another update as soon as we have more information.
Posted Nov 25, 2022 - 12:40 EST
This incident affected: FreshBooks Payments.