FreshBooks - Investigating Issue

Incident Report for FreshBooks

Resolved

We have resolved the issue impacting PDFs in FreshBooks. Thank you for your patience while we worked to fix the issue. Check back here for any further updates.
Posted May 02, 2022 - 16:46 EDT

Investigating

We’re currently investigating reports of intermittent problems with PDF generation on FreshBooks. We will post updates as soon as we have them.
Posted May 02, 2022 - 11:05 EDT
This incident affected: FreshBooks.