Some users unable to save Invoices, Estimates, Expenses
Incident Report for FreshBooks
Resolved
We have resolved the issue impacting FreshBooks. Thank you for your patience while we worked to fix the issue. Check back here for any further updates.
Posted Feb 07, 2023 - 15:59 EST
Monitoring
We have rolled back the changes impacting FreshBooks and will continue to monitor it to ensure there’s no further downtime. Feel free to check back here for any further updates.
Posted Feb 06, 2023 - 18:06 EST
Investigating
We are currently investigating an issue reported earlier today which affects some users' ability to save Invoices, Estimates and Expenses. The issue appears to be limited to a small number of users based on reported cases. We are aware of the issue and are currently working toward identifying the causes and solution. Apologies to affected users for any inconvenience this may cause.
Posted Feb 06, 2023 - 16:58 EST
This incident affected: FreshBooks.