FreshBooks - Down
Incident Report for FreshBooks
Resolved
This incident has now been resolved, FreshBooks services are functional again. We thank you all for your patience and understanding.
Posted Jul 11, 2022 - 12:13 EDT
Monitoring
We are continuing to monitor the issue that caused FreshBooks to become unavailable and to ensure that our fix has been fully implemented successfully. Updates will be provided as soon as new details become available.
Posted Jul 11, 2022 - 12:00 EDT
Identified
The issue has been identified and a fix is being implemented.
Posted Jul 11, 2022 - 11:55 EDT
Investigating
FreshBooks is currently down, and our team is working hard to get it back up and running. We will post updates as soon as we have them.
Posted Jul 11, 2022 - 11:33 EDT
This incident affected: FreshBooks, Android App, and iOS App.