FreshBooks - Access Issues

Incident Report for FreshBooks

Resolved

We have resolved the issue impacting FreshBooks. Thank you for your patience while we worked to fix the issue. Check back here for any further updates.
Posted 3 years ago. May 06, 2022 - 18:00 EDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted 3 years ago. May 06, 2022 - 15:42 EDT

Investigating

We’re currently experiencing an issue which may prevent users from accessing FreshBooks using certain browsers, including Safari. We will post another update as soon as we have more information.
Posted 3 years ago. May 06, 2022 - 15:28 EDT
This incident affected: FreshBooks.