Investigating
Incident Report for FreshBooks
Resolved
We have concluded our investigation and FreshBooks availability has been restored, New FreshBooks is now fully operational. We apologize for any inconveniences this may have caused.
Posted 3 months ago. Mar 05, 2019 - 18:04 EST
Investigating
We have received reports of an issue with FreshBooks availability and are working to resolve it as quickly as possible. We apologize for any inconvenience this may be causing. We will post another update when we have more information.
Posted 3 months ago. Mar 05, 2019 - 17:09 EST
This incident affected: Automatic Expense Import.