FreshBooks - Invoice & Estimate PDF Generation Issue
Incident Report for FreshBooks
Resolved
The issue impacting PDF generation on FreshBooks is now resolved.
Posted May 31, 2022 - 10:51 EDT
Investigating
There’s currently an issue generating PDFs of Invoices & Estimates on FreshBooks. We are investigating the issue. Please check back for further updates.
Posted May 31, 2022 - 10:44 EDT
This incident affected: FreshBooks.