FreshBooks - Investigating Issue
Incident Report for FreshBooks
Resolved
We have resolved the issue impacting FreshBooks. Thank you for your patience while we worked to fix the issue. Check back here for any further updates.
Posted May 25, 2020 - 13:56 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted May 21, 2020 - 14:10 EDT
Investigating
We’re currently experiencing some delays with Bank Import on FreshBooks. We will post updates as soon as we have them.
Posted May 20, 2020 - 15:56 EDT
This incident affected: FreshBooks, FreshBooks Classic, and Automatic Expense Import.