FreshBooks Payroll - Monitoring

Incident Report for FreshBooks

Resolved

The issue impacting FreshBooks Payroll is now resolved. Thank you for your patience while we worked to fix the issue.
Posted Jun 26, 2025 - 16:53 EDT

Monitoring

We are currently monitoring reported issues impacting FreshBooks Payroll, and will continue to monitor it to ensure there are no further issues. Feel free to check back here for any further updates.
Posted Jun 26, 2025 - 15:46 EDT
This incident affected: FreshBooks.