FreshBooks - Unable to Signup
Incident Report for FreshBooks
Resolved
We have resolved the issue impacting FreshBooks signups. Thank you for your patience while we worked to fix the issue.
Posted Nov 23, 2021 - 12:43 EST
Monitoring
We have fixed the issue impacting the ability to create new FreshBooks signups and will continue to monitor it to ensure there’s no further difficulties. Feel free to check back here for any further updates.
Posted Nov 23, 2021 - 10:57 EST
Investigating
There’s currently an issue with signing up for a new account on FreshBooks. We’ve identified the problem and are working to fix it. Please check back for further updates.
Posted Nov 23, 2021 - 10:36 EST
This incident affected: FreshBooks.