Phone System Issue
Incident Report for FreshBooks
Resolved
Our phone incident has been resolved. Thank you for your patience.
Posted Sep 20, 2021 - 13:28 EDT
Identified
Our phone provider has identified the issue and mitigation steps are in progress. Please visit https://support.freshbooks.com/hc/en-us for FAQ's and help until this is solved.
Posted Sep 20, 2021 - 11:07 EDT
Investigating
We are currently investigating an issue with our phone system not being able to connect calls. We will update as we find out more. Please visit https://support.freshbooks.com/hc/en-us for FAQ's and help.
Posted Sep 20, 2021 - 10:57 EDT
This incident affected: FreshBooks and FreshBooks Classic.