FreshBooks Classic Access
Incident Report for FreshBooks
Resolved
Access to FreshBooks Classic is confirmed to be fully resolved. We apologize for the inconvenience.
Posted over 1 year ago. Jun 20, 2017 - 15:20 EDT
Monitoring
Access to FreshBooks Classic appears to be recovering.
Posted over 1 year ago. Jun 20, 2017 - 14:08 EDT
Investigating
We're currently investigating reports of difficulties accessing the FreshBooks Classic service.
Posted over 1 year ago. Jun 20, 2017 - 13:52 EDT