Payment gateway issues
Incident Report for FreshBooks
Resolved
We have resolved the issue impacting FreshBooks. Thank you for your patience while we worked to fix the issue. Check back here for any further updates.
Posted Jan 24, 2023 - 07:07 EST
Monitoring
Issues Impacting WePay transactions have been identified and remediated. We will continue to monitor it to ensure there’s no further downtime. Feel free to check back here for any further updates.
Posted Jan 23, 2023 - 19:21 EST
Investigating
We are currently experiencing an issue with WePay. The team is aware of the problem and is working to resolve it, but you may notice issues with processing transactions. We will post another update as soon as we have more information.
Posted Jan 23, 2023 - 16:12 EST
This incident affected: FreshBooks and FreshBooks Payments.