Phone System Issue
Incident Report for FreshBooks
Resolved
The issue we were experiencing with our phone system has now been resolved. Thank you for your patience.
Posted Nov 12, 2020 - 17:14 EST
Update
Please note, phone support is currently unavailable while we continue to investigate an issue with our phone system. Please email us at support@freshbooks.com in the meantime.
Posted Nov 12, 2020 - 16:32 EST
Investigating
We are currently investigating an intermittent issue with our phone system where we cannot hear your audio for the first 25 seconds. Please stay on the line and we will get to your call.
Posted Nov 12, 2020 - 15:55 EST