FreshBooks - Errors Registering New Users via Partnership Signup Flow
Incident Report for FreshBooks
Resolved
We have resolved the issue impacting the registration of new users via our partnership signup flow on FreshBooks. Thank you for your patience while we worked to fix the issue.
Posted Mar 22, 2022 - 09:48 EDT
Monitoring
We have fixed the issue impacting partnership signup flow on FreshBooks and will continue to monitor it to ensure there are no further issues. Feel free to check back here for any further updates.
Posted Mar 21, 2022 - 10:11 EDT
Identified
We have identified the issue impacting FreshBooks registration via the Partnership Signup Flow and are working quickly to fix it. We will post an update as soon as everything is resolved.
Posted Mar 21, 2022 - 09:26 EDT
Investigating
There’s currently an issue with registering new users via our partnership signup flow on FreshBooks. We’ve identified the problem and are working to fix it, however you may be unable to register for a new FreshBooks account via the partnership flow at this time. Please check back for further updates.
Posted Mar 21, 2022 - 09:10 EDT
This incident affected: FreshBooks.