FreshBooks.com - Access Issues
Incident Report for FreshBooks
Resolved
We have resolved the issue impacting the FreshBooks.com website and access to all pages has been restored.
Thank you for your patience while we worked to fix the issue. Check back here for any further updates.
Posted Jan 24, 2022 - 14:03 EST
Investigating
We’re currently experiencing an issue which may prevent users from accessing the freshbooks.com website, as well as our Support pages. Please note, account access is not affected at this time. Accounts are still fully functional and you may log in to your FreshBooks account at my.freshbooks.com

Thank you for your patience as we work to resolve this issue. Feel free to check back here for updates.
Posted Jan 24, 2022 - 13:32 EST
This incident affected: FreshBooks, Automatic Expense Import, FreshBooks Payments, Android App, iOS App, and FreshBooks.com Website.