FreshBooks - Bank Connection Issue
Incident Report for FreshBooks
Resolved
We have resolved the issue impacting FreshBooks' Bank Connection. Thank you for your patience while we worked to fix the issue. Check back here for any further updates.
Posted May 25, 2023 - 16:30 EDT
Investigating
We’re currently investigating reports of issues with the Bank Import connection on FreshBooks. Connecting your bank account, refreshing the connection, and expense import can result in an error.
We will post updates as soon as we have them.
Posted May 25, 2023 - 14:38 EDT
This incident affected: FreshBooks.