FreshBooks - Access Issues

Incident Report for FreshBooks

Resolved

This incident has been resolved.
Posted Sep 11, 2025 - 12:48 EDT

Monitoring

A fix has been implementing and we are monitoring the results.
Posted Sep 11, 2025 - 12:29 EDT

Investigating

We’re currently experiencing an issue which may prevent new users from accessing FreshBooks after signing up. Our team is currently investigating the cause and we'll post updates as soon as possible.
Posted Sep 11, 2025 - 12:08 EDT
This incident affected: FreshBooks.