FreshBooks - Investigating Issue
Incident Report for FreshBooks
Resolved
We have resolved the issue impacting Email Delivery in FreshBooks. Thank you for your patience while we worked to fix the issue. Check back here for any further updates.
Posted Mar 17, 2021 - 17:32 EDT
Monitoring
We have implemented some resolutions to the issue impacting Email Delivery and we're noticing improvements in delivery times. However, we are still experiencing delays and we will continue to monitor the situation until it is full resolved. Feel free to check back here for any further updates.
Posted Mar 12, 2021 - 07:26 EST
Investigating
There’s currently an issue with email delivery being delayed on FreshBooks. We are investigating the issue and are working to fix it, however you may notice delays in emails being sent at this time. Please check back for further updates.
Posted Mar 12, 2021 - 07:13 EST
This incident affected: FreshBooks and FreshBooks Classic.