FreshBooks - Investigating Issue
Incident Report for FreshBooks
Postmortem

Connectivity issues between two major cloud providers resulted in slowness and elevated errors in our applications. These issues have been resolved by the involved cloud providers.

Posted Mar 27, 2020 - 17:31 EDT

Resolved
The issue impacting FreshBooks have been resolved. Thank you for your patience during this time. Check back here for any further updates.
Posted Mar 27, 2020 - 17:30 EDT
Monitoring
The connectivity issues have been identified as being between cloud providers. We are continuing to monitor for any impact on FreshBooks users.
Posted Mar 27, 2020 - 16:47 EDT
Investigating
We’re currently investigating reports of issues accessing FreshBooks. We will post updates as soon as we have them.
Posted Mar 27, 2020 - 16:15 EDT
This incident affected: FreshBooks and FreshBooks Classic.