FreshBooks - Component not working
Incident Report for FreshBooks
Resolved
We have resolved the issue impacting FreshBooks. Thank you for your patience while we worked to fix the issue. Check back here for any further updates.
Posted Jul 28, 2022 - 17:02 EDT
Monitoring
The issue affecting one of our external partners has been fixed along with the impact to FreshBooks. We will continue to monitor it to ensure there’s no further disruption. Feel free to check back here for any further updates.
Posted Jul 28, 2022 - 15:35 EDT
Update
We are continuing to work on a fix for this issue.
Posted Jul 28, 2022 - 13:58 EDT
Identified
Due to problems with an external service, there’s currently an issue with the Billing and Upgrade page on the FreshBooks platform, as well as freshbooks.com. We’ve identified the problem and are working to fix it, however you may be unable to use access the Billing and Upgrade and freshbooks.com pages at this time. Please check back for further updates.
Posted Jul 28, 2022 - 13:44 EDT
This incident affected: FreshBooks and FreshBooks.com Website.