FreshBooks - Investigating Issue
Incident Report for FreshBooks
Postmortem

This morning FreshBooks employees noticed slowness on the FreshBooks platform.

This was quickly isolated to be an issue with our internal network, and not something that affected our customers.

Posted Oct 29, 2019 - 11:07 EDT

Resolved
We have resolved the issue impacting FreshBooks. Thank you for your patience while we worked to fix the issue. Check back here for any further updates.
Posted Oct 29, 2019 - 10:45 EDT
Investigating
We’re currently investigating reports of log in issues on FreshBooks. We will post updates as soon as we have them.
Posted Oct 29, 2019 - 10:40 EDT
This incident affected: FreshBooks.